0
Fixed
User2883 5 months ago in Remote Management • updated by Richard 4 months ago 7

I cannot revert my setting to 0 seconds per startup.

When restarting the kiosk-browser-app the page is stuck on
"Please wait..."
I belive that this setting is the cause of it.

How i tested

Connectivity -> Delayed Load on Startup (seconds) set to 1.
Remote restart the device a few times.
Observe stuck on "Please wait..." screeen

However after a minute it does reload I noticed now so It seems that it should be minutes there instead of seconds.

Under review

Hi,


Does it come up with an error when trying to set it to zero?

Yes it says the number must be greater than 0. Also its definitly minutes not seconds. 1 minute is too long for a delayed startup.

We've fixed that bug within remote management in our development version (not being able to set as 0), which will be rolled out soon.


It's definately seconds, but to be honest 1 second isn't really a valid option because it just wouldn't work effectively (far too quick and probably wouldn't be executed in startup window). On the device which is using the remote management profile, please check how many seconds are being displayed within Settings > Connectivity > Delayed Load on Startup. I suspect the idle timeout is actually what is causing the page to reload after the first minute (or another setting).


I've personally checked the code and its working on the basis of seconds.

Having tested this further, setting this to one second doesn't work (as suspected) due to the delays in the app launching etc... This isn't because its taking one minute, since setting it to 2 functions perfectly normal.

Fixed

We've fixed the remote management bug for the next release (hopefully happening today). However as described 1 second is too short a delay for the function to work correctly.

We recommend a minimum of 5 seconds, anything less probably won't work reliably due to the speed of the app launching on device startup.