As you are probably using a tablet/mobile it will automatically load the mobile page by default (as will any browser installed on the device). You must tell the browser you wish to identify itself as a device with a large screen (such as a desktop PC) to get the correct page, some websites still ignore this but it depends on how the site has been coded to work. You must go to Settings > Page & Content > User Agent > Set to Desktop.

This article was helpful for 2 people. Is this article helpful for you?